[Ltb-users] posthook doesn't working

Angel Docampo adocampo at dltec.net
Tue Nov 28 16:23:58 CET 2017


El mar, 28-11-2017 a las 16:06 +0100, Clément OUDOT escribió:

2017-11-28 15:55 GMT+01:00 Angel Docampo <adocampo at dltec.net<mailto:adocampo at dltec.net>>:



Regarding the documentation, seems all documentation which refers posthook is the same [:-)]



Indeed but for some features, documentation can be different.



I already enabled debug, must I see something on apache logs?



No, it should be printed on the SSP web application page.




I see nothing relevant.. do you?



No.


Ok, on ssp_error I see a lot of "PHP Notice:  Undefined variable: logo " and perhaps something meaningful
PHP Parse error: syntax error, unexpected end of file in /usr/share/self-service-password/conf/config.inc.php on line 291

That line is, precisely, the posthook call, what its like:
$posthook = "/usr/share/self-service-password/posthook.sh";

So, I've set the $logo=""; and tried again, so now there is no error, nor the "unexpected end of line" related to posthook line, but it still doesn't writes the test file on tmp.
I've repeated the procedure three times and no error log since before modifying $logo variable.

I beg you to take a lok on the entire config.inc.php here: https://hastebin.com/orinanizur.xml

Do you see something?



More information about the ltb-users mailing list