[Ltb-users] Self service password trouble.

Clément OUDOT clem.oudot at gmail.com
Wed May 18 15:08:34 CEST 2011


2011/5/18 admin <admin at webmerchantsinc.com>:
> Hello, Clément Oudot.

Hello "admin",


> Sorry for inconvenience.
> I tried to register an account in "LDAP Tool Box" Bug Tracker, but I think
> that Redmine is in Manual account activation mode and I can't log in.

you should have received a mail to confirm your subscription to the site.

> I have trouble to start using Self service password.
> All seems fine, but when I try to change password I received this message:
>
> Password was refused by the LDAP directory
>
> Warning: preg_match_all() [function.preg-match-all]: Compilation failed:
> missing terminating ] for character class at offset 2 in
> /home/ssp/functions.inc.php on line 152
> Warning: ldap_mod_replace() [function.ldap-mod-replace]: Modify: No such
> attribute in /home/ssp/functions.inc.php on line 235
>
> OS: Ubuntu 9.04
> Software:
> PHP 5.2.6-3ubuntu4.6 with Suhosin-Patch 0.9.6.2 (cli) (built: Sep 16 2010
> 19:52:51)
> Copyright (c) 1997-2008 The PHP Group
> Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
>
> php5-ldap  php5-mhash
> Ldap:
> Windows 2003 Active directory
>
> Script settings:
> $ldap_filter = "(&(objectClass=user)(sAMAccountName={login}))";
> $ad_mode = true;
> $samba_mode = true;
> $who_change_password = "manager";
>
> $ldap_url
> $ldap_binddn - is a domain admin.
> $ldap_bindpw
> $ldap_base
> all is fine, I checked them manually with ldapsearch.
>
> If you see what can be wrong with my settings ?

You cannot use ad_mode and samba_mode at the same time. Set
$samba_mode to false and try again.

Clément.

PS : you can subscribe to user list to follow this discussion.


More information about the ltb-users mailing list